< prev index next >

make/linux/makefiles/gcc.make

Print this page
rev 7793 : 8073315: Enable gcc -Wtype-limits and fix upcoming issues.

@@ -219,10 +219,13 @@
 ifeq ($(USE_CLANG),)
   # Since GCC 4.3, -Wconversion has changed its meanings to warn these implicit
   # conversions which might affect the values. Only enable it in earlier versions.
   ifeq "$(shell expr \( $(CC_VER_MAJOR) \> 4 \) \| \( \( $(CC_VER_MAJOR) = 4 \) \& \( $(CC_VER_MINOR) \>= 3 \) \))" "0"
     WARNING_FLAGS += -Wconversion
+  else 
+    # This flag is only known since GCC 4.3.
+    WARNING_FLAGS += -Wtype-limits
   endif
 endif
 
 CFLAGS_WARN/DEFAULT = $(WARNINGS_ARE_ERRORS) $(WARNING_FLAGS)
 
< prev index next >