< prev index next >

src/java.base/share/classes/jdk/internal/org/objectweb/asm/tree/FieldNode.java

Print this page
rev 47452 : imported patch jdk-new-asmv6.patch

@@ -171,11 +171,11 @@
      * @throws IllegalStateException
      *             If a subclass calls this constructor.
      */
     public FieldNode(final int access, final String name, final String desc,
             final String signature, final Object value) {
-        this(Opcodes.ASM5, access, name, desc, signature, value);
+        this(Opcodes.ASM6, access, name, desc, signature, value);
         if (getClass() != FieldNode.class) {
             throw new IllegalStateException();
         }
     }
 

@@ -274,12 +274,12 @@
      * This methods checks that this node, and all its nodes recursively, do not
      * contain elements that were introduced in more recent versions of the ASM
      * API than the given version.
      *
      * @param api
-     *            an ASM API version. Must be one of {@link Opcodes#ASM4} or
-     *            {@link Opcodes#ASM5}.
+     *            an ASM API version. Must be one of {@link Opcodes#ASM4},
+     *            {@link Opcodes#ASM5} or {@link Opcodes#ASM6}.
      */
     public void check(final int api) {
         if (api == Opcodes.ASM4) {
             if (visibleTypeAnnotations != null
                     && visibleTypeAnnotations.size() > 0) {
< prev index next >